Redistribution of EIGRP and OSPF
These labs are not as good as the labs in our full blown CCNA Lab Workbook. The labs in our full blown CCNA lab workbook include theory as we step you through each lab, detailed information on why you are entering each command and review questions and answers at the end of the labs. So these labs are ok for free…but we offer a much better product consisting of 60 labs covering 400 pages of CCNA material to help you pass your CCNA Certification Exam in the workbook at this link CCNA Lab Workbook!
Objective:
In this lab you will redistribute the dynamic routing protocols EIGRP and OSPF. You will then run basic testing commands to verify all links and protocols are working properly.
Hardware Requirements:
· Two Cisco routers with one Ethernet port and one serial port
· Two Cisco routers with two serial ports
· Cisco IOS 12.0 or higher
· A PC running a terminal emulation program
· Three back to back DTE/DCE serial cables
· Cisco console kit
Router Configurations
Router 1
Router#conf t
Router(config)#hostname R1
R1(config)#enable password cisco
R1(config)#line vty 0 4
R1(config-line)# password cisco
R1(config-line)# login
R1(config)#int Loopback0
R1(config-if)# ip address 1.1.1.1 255.255.255.255
R1(config-if)# no shut
R1(config)#int s0
R1(config-if)# ip address 10.1.1.1 255.0.0.0
R1(config-if)# clockrate 64000
R1(config-if)# no shut
R1(config)#int s1
R1(config-if)# ip address 11.1.1.1 255.0.0.0
R1(config-if)# clockrate 64000
R1(config-if)# no shut
R1(config)#router ospf 100
R1(config-router)# network 10.0.0.0 0.255.255.255 area 0
R1(config-router)# network 11.0.0.0 0.255.255.255 area 0
R1(config-router)#end
R1#wr
Router 2
Router#conf t
Router(config)#hostname R2
R2(config)#enable password cisco
R2(config)#line vty 0 4
R2(config-line)# password cisco
R2(config-line)# login
R2(config)#int Loopback0
R2(config-if)# ip address 2.2.2.2 255.255.255.255
R2(config-if)# no shut
R2(config)#int Loopback1
R2(config-if)# ip address 2.2.2.1 255.255.255.255
R2(config-if)# no shut
R2(config)#int Loopback3
R2(config-if)# ip address 20.20.20.20 255.0.0.0
R2(config-if)# no shut
R2(config-if)#int s0
R2(config-if)# ip address 10.1.1.2 255.0.0.0
R2(config-if)# no shut
R2(config)#int s1
R2(config-if)# ip address 12.1.1.2 255.255.255.0
R2(config-if)# no shut
R2(config)#router eigrp 200
R2(config-router)# redistribute ospf 100 metric 200000 5 100 200 100
R2(config-router)# network 12.0.0.0
R2(config-router)# network 20.0.0.0
R2(config)#router ospf 100
R2(config-router)# redistribute eigrp 200 subnets
R2(config-router)# network 2.2.2.2 0.0.0.0 area 0
R2(config-router)# network 10.0.0.0 0.255.255.255 area 0
R2(config-router)#exit
R2(config)#no ip classless
R2(config)#end
R2#wr
Router 3
Router#conf t
R3(config)#hostname R3
R3(config)#enable password cisco
R3(config)#line vty 0 4
R3(config-line)# password cisco
R3(config-line)# login
R3(config)#int Loopback0
R3(config-if)# ip address 3.3.3.3 255.255.255.255
R3(config-if)# no shut
R3(config)#int Loopback1
R3(config-if)# ip address 3.3.3.4 255.255.255.255
R3(config-if)# no shut
R3(config)#int e0
R3(config-if)# ip address 193.1.1.3 255.255.255.0
R3(config-if)# no keepalive
R3(config-if)# no shut
R3(config)#int s0
R3(config-if)# ip address 11.1.1.3 255.0.0.0
R3(config-if)# no shut
R3(config)#router ospf 100
R3(config-router)# network 3.3.3.4 0.0.0.0 area 0
R3(config-router)# network 11.0.0.0 0.255.255.255 area 0
R3(config-router)# network 193.1.1.0 0.0.0.255 area 0
R3(config-router)# exit
R3(config)#no ip classless
R3(config-line)#end
R3#wr
Router 4
Router#conf t
Router(config)#hostname R4
R4(config)#enable password cisco
R4(config)#line vty 0 4
R4(config-line)# password cisco
R4(config-line)# login
R4(config)#int Loopback0
R4(config-if)# ip address 4.4.4.4 255.255.255.255
R4(config-if)# no shut
R4(config)#int e0
R4(config-if)# ip address 192.168.1.4 255.255.255.0
R4(config-if)# no keepalive
R4(config-if)# no shut
R4(config)#int s0
R4(config-if)# ip address 12.1.1.4 255.0.0.0
R4(config-if)# no shut
R4(config-if)# clockrate 64000
R4(config)#router eigrp 200
R4(config-router)# network 4.0.0.0
R4(config-router)# network 12.0.0.0
R4(config-router)# network 192.168.1.0
R4(config)#no ip classless
R4(config)#end
R4# wr
Testing the Configuration
Router 1
R1#sho ip route
(Output omitted)
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.4 [110/782] via 11.1.1.3, Serial0/1
O E2 4.0.0.0/8 [110/20] via 10.1.1.2, Serial0/0
O E2 20.0.0.0/8 [110/20] via 10.1.1.2, Serial0/0
C 10.0.0.0/8 is directly connected, Serial0/0
C 11.0.0.0/8 is directly connected, Serial0/1
O 193.1.1.0/24 [110/791] via 11.1.1.3, Serial0/1
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O E2 12.1.1.0/24 [110/20] via 10.1.1.2, Serial0/0
O E2 12.0.0.0/8 [110/20] via 10.1.1.2, Serial0/0
O E2 192.168.1.0/24 [110/20] via 10.1.1.2, Serial0/0
R1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/58/60 ms
R1#ping 192.168.1.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms
R1#sho ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
20.20.20.20 1 FULL/ – 00:00:36 10.1.1.2 Serial0/0
3.3.3.4 1 FULL/ – 00:00:35 11.1.1.3 Serial0/1
Router 2
R2#sho ip route
(Output omitted)
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 2 subnets
C 2.2.2.2 is directly connected, Loopback0
C 2.2.2.1 is directly connected, Loopback1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.4 [110/846] via 10.1.1.1, 00:36:00, Serial0
D 4.0.0.0/8 [90/2297856] via 12.1.1.4, 00:46:13, Serial1
C 20.0.0.0/8 is directly connected, Loopback3
C 10.0.0.0/8 is directly connected, Serial0
O 11.0.0.0/8 [110/845] via 10.1.1.1, 00:36:00, Serial0
O 193.1.1.0/24 [110/855] via 10.1.1.1, 00:36:00, Serial0
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 12.0.0.0/8 is a summary, 00:46:18, Null0
C 12.1.1.0/24 is directly connected, Serial1
D 192.168.1.0/24 [90/2195456] via 12.1.1.4, 00:46:13, Serial1
R2#ping 193.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 193.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/67/80 ms
R2#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms
R2#sho ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/ – 00:00:37 10.1.1.1 Serial0
R2#sho ip eigrp nei
IP-EIGRP neighbors for process 200
H Address Interface Hold Uptime SRTT RTO Q
Seq (sec) (ms) Cnt Num
0 12.1.1.4 Se1 13 00:46:56 543 3258 0 3
Router 3
R3#R3#sho ip route
(Output omitted)
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/846] via 11.1.1.1, 00:34:05, Serial0
3.0.0.0/32 is subnetted, 2 subnets
C 3.3.3.3 is directly connected, Loopback0
C 3.3.3.4 is directly connected, Loopback1
O E2 4.0.0.0/8 [110/20] via 11.1.1.1, 00:34:05, Serial0
O E2 20.0.0.0/8 [110/20] via 11.1.1.1, 00:34:05, Serial0
O 10.0.0.0/8 [110/845] via 11.1.1.1, 00:34:05, Serial0
C 11.0.0.0/8 is directly connected, Serial0
C 193.1.1.0/24 is directly connected, Ethernet0
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O E2 12.1.1.0/24 [110/20] via 11.1.1.1, 00:34:05, Serial0
O E2 12.0.0.0/8 [110/20] via 11.1.1.1, 00:34:05, Serial0
O E2 192.168.1.0/24 [110/20] via 11.1.1.1, 00:34:05, Serial0
R3#ping 192.168.1.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/96/112 ms
R3#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/96/112 ms
R3#sho ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/ – 00:00:37 11.1.1.1 Serial0
Router 4
R4#sho ip route
(Output omitted)
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
D EX 2.2.2.2 [170/2171136] via 12.1.1.2, 00:32:38, Serial0
3.0.0.0/32 is subnetted, 1 subnets
D EX 3.3.3.4 [170/2171136] via 12.1.1.2, 00:32:39, Serial0
4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 4.4.4.4/32 is directly connected, Loopback0
D 4.0.0.0/8 is a summary, 01:02:25, Null0
D 20.0.0.0/8 [90/2297856] via 12.1.1.2, 01:02:20, Serial0
D EX 10.0.0.0/8 [170/2171136] via 12.1.1.2, 00:32:39, Serial0
D EX 11.0.0.0/8 [170/2171136] via 12.1.1.2, 00:32:39, Serial0
D EX 193.1.1.0/24 [170/2171136] via 12.1.1.2, 00:32:39, Serial0
C 12.0.0.0/8 is directly connected, Serial0
C 192.168.1.0/24 is directly connected, Ethernet0
R4#ping 193.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 193.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/87/88 ms
R4#ping 3.3.3.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/88/88 ms