Configuring a Frame Relay with Virtual Links
These labs are not as good as the labs in our full blown CCNA Lab Workbook. The labs in our full blown CCNA lab workbook include theory as we step you through each lab, detailed information on why you are entering each command and review questions and answers at the end of the labs. So these labs are ok for free…but we offer a much better product consisting of 60 labs covering 400 pages of CCNA material to help you pass your CCNA Certification Exam in the workbook at this link CCNA Lab Workbook!
Objective:
We are going to add a virtual link to our frame relay PSPF lab.
Prerequisite:
You must have completed the prior lab as this lab builds on top of our prior lab. Do not erase the configuration from the previous lab.
Hardware Requirements:
· One Cisco router with two serial ports
· Two Cisco routers with one Ethernet port and two serial ports
· Two Cisco routers with one Ethernet port and one serial port
· Cisco IOS 12.0 or higher
· A PC running a terminal emulation program
· Four back to back DTE/DCE serial cable s
· Cisco console kit
Router Configuration
Router 4
R4#conf t
R4(config)#host Router
Router(config)#hostname R4
R4(config)#enable password cisco
R4(config)#line vty 0 4
R4(config-line)# password cisco
R4(config-line)# login
R4(config)#int Loopback0
R4(config-if)# ip address 4.4.4.1 255.255.255.255
R4(config-if)# no shut
R4(config)#int s0
R4(config-if)# ip address 12.1.1.4 255.255.255.0
R4(config-if)# no shut
R4(config)#router ospf 100
R4(config-router)# network 4.4.4.1 0.0.0.0 area 2
R4(config-router)# network 12.1.1.0 0.0.0.255 area 1
R4(config-router)# area 1 virtual-link 2.2.2.2
R4(config-router)# end
R4#
Testing
Frame Relay
FR#show frame route
02:57:09: %SYS-5-CONFIG_I: Configured from console by console
Input Intf Input Dlci Output Intf Output Dlci
Status
Serial0/0 100 Serial0/1 200 active
Serial0/1 200 Serial0/0 100 active
Router 1
R1#sho ip route
(Output omitted)
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 2 subnets
C 1.1.1.1 is directly connected, Loopback0
C 1.1.1.2 is directly connected, Loopback1
2.0.0.0/32 is subnetted, 2 subnets
O 2.2.2.2
O IA 2.2.2.1 [110/65] via 10.1.1.2, 00:05:05, Serial0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.2 [110/129] via 10.1.1.2, 00:05:05, Serial0
4.0.0.0/32 is subnetted, 1 subnets
O IA 4.4.4.1 [110/193] via 10.1.1.2, 00:05:05, Serial0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0
11.0.0.0/24 is subnetted, 1 subnets
O IA 11.1.1.0 [110/128] via 10.1.1.2, 00:05:05, Serial0
O IA 193.1.1.0/24 [110/74] via 10.1.1.2, 00:05:07, Serial0
12.0.0.0/24 is subnetted, 1 subnets
O IA 12.1.1.0 [110/192] via 10.1.1.2, 00:05:07, Serial0
C 192.1.1.0/24 is directly connected, Ethernet0
O IA 194.1.1.0/24 [110/138] via 10.1.1.2, 00:05:07, Serial0
R1#ping 4.4.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 116/124/148 ms
R1#ping 3.3.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/97/120 ms
R1#sho ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 100 FULL/DR 00:01:37 10.1.1.2 Serial0
Router 2
R2#sh ip route
(Output omitted)
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.2 [110/65] via 10.1.1.1, 00:09:16, Serial0
2.0.0.0/32 is subnetted, 2 subnets
C 2.2.2.2 is directly connected, Loopback1
C 2.2.2.1 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.2 [110/65] via 11.1.1.3, 00:11:33, Serial1
4.0.0.0/32 is subnetted, 1 subnets
O IA 4.4.4.1 [110/129] via 11.1.1.3, 00:09:16, Serial1
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0
11.0.0.0/24 is subnetted, 1 subnets
C 11.1.1.0 is directly connected, Serial1
C 193.1.1.0/24 is directly connected, Ethernet0
12.0.0.0/24 is subnetted, 1 subnets
O 12.1.1.0 [110/128] via 11.1.1.3, 00:11:35, Serial1
O 192.1.1.0/24 [110/74] via 10.1.1.1, 00:09:18, Serial0
O 194.1.1.0/24 [110/74] via 11.1.1.3, 00:11:35, Serial1
R2#ping 1.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/60 ms
R2#ping 4.4.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/68/84 ms
R2#ping 194.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 194.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/52 ms
R2#sho ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
1.1.1.2 1 FULL/BDR 00:01:47 10.1.1.1 Serial0
3.3.3.2 0 FULL/ – 00:00:38 11.1.1.3 Serial1
R2#sho ip ospf virtual-links
Virtual Link OSPF_VL0 to router 4.4.4.1 is up
Run as demand circuit
DoNotAge LSA not allowed (Number of DCbitless LSA is 1).
Transit area 1, via interface Serial1, Cost of using 128
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:09
Adjacency State FULL (Hello suppressed)
Router 3
R3#sh ip route
(Output omitted)
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.2 [110/129] via 11.1.1.2, 00:14:40, Serial0
2.0.0.0/32 is subnetted, 2 subnets
O IA 2.2.2.2 [110/65] via 11.1.1.2, 00:16:55, Serial0
O 2.2.2.1 [110/65] via 11.1.1.2, 00:17:05, Serial0
3.0.0.0/32 is subnetted, 2 subnets
C 3.3.3.2 is directly connected, Loopback1
C 3.3.3.1 is directly connected, Loopback0
4.0.0.0/32 is subnetted, 1 subnets
O IA 4.4.4.1 [110/65] via 12.1.1.4, 00:15:09, Serial1
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.1.1.0 [110/128] via 11.1.1.2, 00:14:44, Serial0
11.0.0.0/24 is subnetted, 1 subnets
C 11.1.1.0 is directly connected, Serial0
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial1
O IA 192.1.1.0/24 [110/138] via 11.1.1.2, 00:14:42, Serial0
O 193.1.1.0/24 [110/74] via 11.1.1.2, 00:17:06, Serial0
C 194.1.1.0/24 is directly connected, Ethernet0
R3#ping 1.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/88/92 ms
R3#ping 4.4.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 4.4.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/56 ms
R3#ping 192.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 192.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/88/92 ms
R3#sho ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1 FULL/ – 00:00:39 11.1.1.2 Serial0
4.4.4.1 1 FULL/ – 00:00:35 12.1.1.4 Serial1
Router 4
R4#sh ip route
(Output omitted)
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.2 [110/193] via 12.1.1.3, 01:42:48, Serial0
2.0.0.0/32 is subnetted, 2 subnets
O 2.2.2.2 [110/129] via 12.1.1.3, 01:42:48, Serial0
O 2.2.2.1 [110/129] via 12.1.1.3, 01:45:13, Serial0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.2 [110/65] via 12.1.1.3, 01:45:13, Serial0
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.1 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
O 10.1.1.0 [110/192] via 12.1.1.3, 01:42:48, Serial0
11.0.0.0/24 is subnetted, 1 subnets
O 11.1.1.0 [110/128] via 12.1.1.3, 01:45:13, Serial0
O 193.1.1.0/24 [110/138] via 12.1.1.3, 01:45:13, Serial0
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial0
O 192.1.1.0/24 [110/202] via 12.1.1.3, 01:42:49, Serial0
O 194.1.1.0/24 [110/74] via 12.1.1.3, 01:45:14, Serial0
R4#ping 1.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 116/116/116 ms
R4#ping 3.3.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms
R4#sho ip ospf vir
Virtual Link OSPF_VL0 to router 2.2.2.2 is up
Run as demand circuit
DoNotAge LSA not allowed (Number of DCbitless LSA is 1).
Transit area 1, via interface Serial0, Cost of using 128
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:05
Adjacency State FULL (Hello suppressed)
R4#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
3.3.3.2 1 FULL/ – 00:00:32 12.1.1.3 Serial0
End of Lab
Frame Relay Review
Questions:
- If your router is sending too much information into the Frame Relay cloud, the service provider tags any return traffic with a _____________ to notify your router to reduce its transmission rate.
- You are troubleshooting your Frame Relay connections. After typing in the ‘show frame-relay pvc’ command, one of your PVCs shows up as DELETED. What causes this? ________________________________________________________________
Answers:
- BECN. The service provider tags any return traffic with a BECN or Backwards Explicit Congestion Notification marking. By default, your router ignores these notifications.
- Three primary PVC states indicate the status of the line. ACTIVE means there are no problems. INACTIVE means that there is a problem with the remote router. DELETED means that there is a problem with your local router. Typically, this is caused by using the incorrect DLCI information. If the DLCI shows up as DELETED under a multipoint configuration, it shows up as DELETED under a point-to-point configuration. If you were physically disconnected from the service provider, you would not see DLCI information (because LMI is used to send the DLCI status of your router).